I suggest you ...

App keeps crashing

I have version 2.01.17 and it keeps crashing when I try to create any list for Horus Heresy v11.003 on an iPhone 6 (iOS 11.4) It just gives the loading circle for about a minute or so and then closes out to my phone’s home screen.

I have deleted and reinstalled the app and redownloaded the file and it still does it.

171 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Stephen shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
completed  ·  AdminJon Taylor (Developer, BattleScribe) responded  · 

The HH Legiones Astartes file is the largest data file (that I know of).

The crashing occurred because on many devices the app would run out of memory (RAM).

In version 2.02 and above, there have been significant memory improvements which may now allow your device to use the file.

Please note this depends heavily on your device – older devices with low amounts of RAM will still struggle. Your mileage may vary.

15 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Thaddaeus Davidson commented  ·   ·  Flag as inappropriate

    I’m on 2.01.20 and the app is totally unusable. Can’t sign into google or Dropbox and that’s where all my rosters are. Happened when I updated to this version.

  • Kenneth commented  ·   ·  Flag as inappropriate

    How the hell has this problem still not been fixed, it’s been well over a year for me.

  • Ed Rose commented  ·   ·  Flag as inappropriate

    I have version 2.19. Every time I try to create a Horus Hersey list. After I input name of list and points, then push the check mark to start. I see the rotating circle for a few seconds, the the program crashes to my home page of my IPad. Why does this happen?

  • Anonymous commented  ·   ·  Flag as inappropriate

    Details:

    Failed to download from one or more repositories

    1) net.battlescribe.model.config.Repository@e01d71: Server returned HTTP response code: 500 for URL: https://battlescribedata.appspot.com/repos/wh40k

    2) https://battlescribedata.appspot.com/repos/wh40k/index.bsi: Server returned HTTP response code: 500 for URL: https://battlescribedata.appspot.com/repos/wh40k/index.bsi

    3) net.battlescribe.model.config.Repository@10cb553: Server returned HTTP response code: 500 for URL: https://battlescribedata.appspot.com/repos/wh40k-killteam

    4) https://battlescribedata.appspot.com/repos/wh40k-killteam/index.bsi: Server returned HTTP response code: 500 for URL: https://battlescribedata.appspot.com/repos/wh40k-killteam/index.bsi
    at net.battlescribe.desktop.a.b$5.a(BattleScribe:401)
    at net.battlescribe.desktop.a.b$5.doInBackground(BattleScribe:361)
    at javax.swing.SwingWorker$1.call(Unknown Source)
    at java.util.concurrent.FutureTask.run(Unknown Source)
    at javax.swing.SwingWorker.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)

  • Anonymous commented  ·   ·  Flag as inappropriate

    i have teh sam eproblem and duplicate is not functionig and it freezes. on my mobile and my pc

  • Blayne commented  ·   ·  Flag as inappropriate

    Im having the smae problem. I mostly use android so i thought it was the device i was usuing so i tried it on another android device as well as an iPad and I get the same results. Hopefully this gets fixed soon

  • Kenneth commented  ·   ·  Flag as inappropriate

    Why hasn’t this been fixed yet? It’s been almost a year with this problem and still nothing.

  • Telcharon commented  ·   ·  Flag as inappropriate

    Using iOS 12 and iPhone 7, with Version 2.01.19, Deleted all the Data and updated to new data. App keeps crashing. (I can press the +, select detachment and faction, but as soon as i want to create it, it crashes)

  • anonym commented  ·   ·  Flag as inappropriate

    Using iOS 12 and iPhone 6, with Version 2.01.19 and gettin the same.
    App keeps crashing and I get a black screen when I want to make a new roster or look at an old one

  • Stephen commented  ·   ·  Flag as inappropriate

    I’ve updated to the newest versions of the app, Horus Heresy data files, and iOS and it still is doing this.
    I’ve deleted and redownloaded as well to no effect.

  • Kenneth commented  ·   ·  Flag as inappropriate

    Same thing with me, except I’m running an iPhone 5. Busy everything is up to date and I’m running 2.01.19. It hasn’t been working for months for me, I was hoping a fix would be released but once again this app is the worst?

  • Luke Evans commented  ·   ·  Flag as inappropriate

    Same issue, used to be only when working on legionnes astartes lists but is now all forces

Feedback and Knowledge Base