BattleScribe

Before your report a problem, make sure you try the basic troubleshooting steps and check the BattleScribe FAQ for answers to common problems.

To report problems with your supporter pass or account, please see this FAQ.

Do NOT report data problems here (missing or incorrect units/models/upgrades/points values/rules/profiles/etc)Instead, make sure you update your data and report any problems to the data authors.

If you are unable to download data, it is likely a temporary problem with the data website. Please be patient and try again later.

For general questions and help, please post on the BattleScribe Reddit
  1. Unable to open an Adeptus Astartes roster

    My Samsung Tab A is unable to open an Adeptus Astartes roster (its fine opening Thousand Sons and Imp Guard. It just keeps telling me I don't have enough RAM, so i put set it to low and it tells me AGAIN that I don't have enough RAM. This is despite the program saying that I have enough ram and suggesting I change the setting.

    5 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    7 comments  ·  Flag idea as inappropriate…  ·  Admin →
  2. Problem with Warhammer 40.000 v1.3.7 Space Marine Battalions

    I have a problem, specifically with (Warhammer 40.000 v1.3.7 data files) Space Marines. I fiddled with it, and I can create and load a Blood Angels Battalion, the same with space marines. I can open the Blood Angels ones, but the minute I put a Space Marine battalion in the roster, I cannot open it, it loads indefinitely. I if put a brigade in, it works. So for me the issue right now is Space Marine battalions' not working. When I try to open a roster containing one, it loads forever. I tried updating several times, saying yes to the…

    4 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Flag idea as inappropriate…  ·  Admin →
  3. Unable to Create Space Marine rosters, causes RAM outage.

    Warhammer 40,000 v1.3.7 unable to create a Space Marine roster. From the moment I tell it to create a roster, the app spins for a good two or three minutes, tells me it can't create the list, even if I tell it to go into Low RAM mode, it'll say it doesn't need to be in Low RAM mode.

    I've tested this with Deathwatch, Blood Angels and Dark Angels. They're all fine, but the regular Space Marine list causes this error.

    6 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  4. Bug Report:

    Bug Report: HTML pages are all blank.

    Just starting today I can no longer see any HTML screens when I try to view a unit's datasheet (using Warhammer 40,000 data). The screen is just completely blank. The Report a Bug, About, and What's New screens are also blank in the app. I tried uninstalling and reinstalling, deleting all my files, and restarting my phone (Galaxy S9), but HTML will still not display.

    I can view unit data using Plan Text, BBCode, and Markdown, but not HTML. The HTML view was the most useful and helpful for me. Is there something…

    18 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Flag idea as inappropriate…  ·  Admin →
  5. Bug fix (instructions on where to report not clear hope this is the right place for data issues)

    BattleScribe can not add more than one Detachment of space marines to space marines list without app crashing when loading list App version is 4.02.04 and using Warhammer 40000 data

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Flag idea as inappropriate…  ·  Admin →
  6. 5 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    under review  ·  4 comments  ·  Flag idea as inappropriate…  ·  Admin →
  7. Loading roster never finishes

    Loading roster never finishes. Happens randomly for some newly created rosters. It says it is loading and then it never actually loads. I am using the latest version of the app. I cleared and re downloaded the data. Problem happening on current paid version of the android app.

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  8. Adeptus Astartes (40k+killteam) still broken and now Killteam repository has vanished

    I've been having the same issue for about 2+ months now with creating and/or viewing Adeptus Astartes rosters with both the Warhammer 40k and Killteam repositories on Android.

    I've tried deleting data, deleting rosters, uninstalling the app, redownloading the app and the repositories multiple times and I still get infinite loading screens and crashes. After another failed attempt today I went to update my data to see if there was a fix, only to find out that the Killteam repository data has vanished entirely?

    Not sure if this is a data author issue or a larger app wide issue but…

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  9. Kill Team Adeptus Astartes crash

    I have Battlescribe v2.02.04, on iPad and Kill Team v1.3.12 and every time I try to load Adeptus Astartes it takes forever to load and before I can even see options it exits out of the program. This does not happen with any other faction.

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  10. Please fix issues with new update 2.02.04

    Since New update- lists for Warhammer 40k on iPhone and iPad just either crash out or load after 2-6 minutes of loading screen. Everything is just now so slow to load. Have deleted everything and reinstalled to no avail .

    4 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
  11. I am unable to add detachments to my space marine roster. Works on other forces but not space marines. Just says creating roster then stops.

    Please fix asap. Reloaded. Updated. Did everything suggested. Again only space marines when trying to add detachment of other space marines

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  12. Html view not working

    In the latest update the html view doesn't appear to be working. I'm on a note 9, no phone software updates since early this month just seems to have happened with this last app update.

    6 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    7 comments  ·  Flag idea as inappropriate…  ·  Admin →
  13. Cannot update my data

    I cannot seem to update my data and it just shows me an error code:

    Details:

    Failed to download from one or more repositories

    1) net.battlescribe.model.config.Repository@55881eaa: Server returned HTTP response code: 500 for URL: https://battlescribedata.appspot.com/repos/wh40k

    2) https://battlescribedata.appspot.com/repos/wh40k/index.bsi: Server returned HTTP response code: 500 for URL: https://battlescribedata.appspot.com/repos/wh40k/index.bsi

    3) net.battlescribe.model.config.Repository@50160565: Server returned HTTP response code: 500 for URL: https://battlescribedata.appspot.com/repos/boltaction

    4) https://battlescribedata.appspot.com/repos/boltaction/index.bsi: Server returned HTTP response code: 500 for URL: https://battlescribedata.appspot.com/repos/boltaction/index.bsi

    5) net.battlescribe.model.config.Repository@3104e37c: Server returned HTTP response code: 500 for URL: https://battlescribedata.appspot.com/repos/adeptus-titanicus

    6) https://battlescribedata.appspot.com/repos/adeptus-titanicus/index.bsi: Server returned HTTP response code: 500 for URL: https://battlescribedata.appspot.com/repos/adeptus-titanicus/index.bsi

    7) net.battlescribe.model.config.Repository@1938015a: Server returned HTTP response code:…

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
  14. App (version 2.02.04) crashes in iOS 12.3.1

    App cannot load older or create new rosters. Deleted it and reinstalled everything including the app itself. This has been going on for quite a while already! Crash is consistent in both iPhone and iPad. Considering I’ve paid for the full version on all formats, I am very frustrated so please make your app work again.

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
  15. Cannot open Rosters

    When opening my rosters I get stuck on the loading roster screen, I’ve read the FAQ and tried leaving the screen on for 20 minutes, as well as deleting and re downloading my data
    I’m on an iPhone 6 using version 2.02.04 of BattleScribe and I have IOS 12.3.1

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
  16. download from repositories broken

    Details:

    Failed to download from one or more repositories

    1) net.battlescribe.model.config.Repository@51ba9180: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

    2) https://battlescribedata.appspot.com/repos/wh40k/index.bsi: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

    3) net.battlescribe.model.config.Repository@70c778c3: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

    4) https://battlescribedata.appspot.com/repos/warhammer-age-of-sigmar/index.bsi: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

    5) net.battlescribe.model.config.Repository@401bb37: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

    6) https://battlescribedata.appspot.com/repos/battlefleetgothic/index.bsi: sun.security.validator.ValidatorException:…

    5 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Flag idea as inappropriate…  ·  Admin →
  17. 2.02.04 consistently slow and/or crashing when loading army lists

    Consistently slow/crashing when attempting to load while creating or modifying a new list. Even crashes on occasion when viewing one.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  18. many features don't show

    Using version 2.01.21 on Android Phone. The "View" function doesn't work at all (leads me to a blank page). Doesn't seem to matter if I use the "eye" symbol or the go to the menu and select "view." "Low Ram Mode" has no effect on this issue.

    Furthermore, if I got to the "About" page, the "About" is blank, as is "Report Bug" and "What's new."

    It was working and isn't after updating, though I don't know which version I was using prior to this version.

    Restarting the phone has no effect, nor does restarting the app.

    5 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Flag idea as inappropriate…  ·  Admin →
  19. Bug: BattleScribe_2.02.04_Installer.dmg has "no mountable file systems".

    I tried to update BattleScribe on a 2010 MacBook Pro running OS X 10.11.6, but I get the message that BattleScribe_2.02.04_Installer.dmg can't be mounted because it has "no mountable file systems."

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  20. TZAANGOR ENLIGHTENED

    In the warscroll you can read: MOUNT: This unit can be mounted on
    Discs of Tzeentch. But in the BattleScribe they are like they were 2 different warscrolls, the ones with the disks are under "uncategorised" and you cannot use mounted ones in a battalion. I suggest to meld in one warscroll and in case you cannot, put both of them in "others" and create the chance of select the mounted ones for batallions.

    Thanks!

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3 4 5 26 27
  • Don't see your idea?

BattleScribe

Feedback and Knowledge Base